Tempo aproximado para leitura: 00:01:00 min
Ocorrência
Ao executar algumas rotinas e processos no Automação de Ponto que envolvem integração com Suricato, é apresentado erro de Timeout, o que fazer?
Erro: Erro no Agente de Envio (mensagem assíncrona). The operation has timed out
Ambiente
RH - RH (Linha RM) - TOTVS Automação de Ponto - Todas as versões
Causa
O incidente ocorre pois na execução do processo e/ou rotina ficam executando por um determinado tempo e este é ultrapassado pelo tempo de execução padrão do banco de dados.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Deverá acessar o local de instalação do RM, pasta RM.Net. Normalmente o caminho padrão é o C:\TOTVS\CorporeRM\RM.Net, mas pode ser que esteja diferente dependendo de como a instalação do sistema foi realizada.
2. Na pasta RM.Net procurar e editar os arquivos:
- Rm.Host.exe.config
- Rm.Host.Service.exe.config
- Rm.exe.config
- Rm.Host.JobRunner.exe.config
3. Deverá inserir a tag <add key="ConEAITimeOut" value="390000000"/> conforme exemplo abaixo:
A tag de timeout deve ser inserida dentro da estrutura <appSettings></appSettings>.
Importante
Após ajustes efetuados, deverá reiniciar o serviço do RM apagando o arquivo _broker.dat.
Saiba mais
Para maiores informações de como reiniciar o serviço do RM acesse o link reiniciar host.
0 Comentários