Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Varejo - Moda - FAT - Validação falhou para chave - CMPFM020



Ocorrência
No módulo Faturamento, ao tentar informar o fornecedor na capa do pedido, no componente CMPFM020, é apresentada a mensagem: Validação falhou para a chave.
mceclip1.png

Ambiente
TOTVS Varejo - TOTVS Moda - Faturamento

Causa
Esse incidente ocorre, pois no cadastro do usuário o mesmo não está flegado com o Tipo Funcional: Fornecedor.

mceclip0.png

Solução
Para solucionar essa validação, realize os seguintes passos:
1. Acesse o componente PESFM010, através do campo Procurar e tecle Tab ou Enter;

mceclip0.png
2. No campo Código, informe o código pessoa, ou caso não conter o código, dê um duplo clique neste campo, para ser habilitada a tela PESFL024. Neste, realize a consulta da pessoa, no campo Nome, acione o asterisco * e informe o nome da pessoa e acione o asterisco * novamente. Em seguida, tecle F4 consultar, para listar as informações e selecione a pessoa que você irá alterar a foto e dê duplo clique no código para retornar a tela do PESFM010;
3. Em seguida, selecione a opção na barra lateral Fornecedor, e preenche os dados do fornecedor e assim que concluído tecle F3 para que seja salvo.
Para visualizar que o usuário está com a flag de fornecedor na tela PESFM010, limpe a consulta através do F2 e consulte o código do cliente novamente.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _