Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Logix - NFE - Erro de SCHEMA na tag xBairro

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao enviar a nota fiscal para a SEFAZ - Secretaria da Fazenda ocorre a mensagem de erro de SCHEMA.
Exemplo da mensagem:
Element '{http://www.portalfiscal.inf.br/nfe}xBairro': [facet 'minLength'] The value has a length of '1'; this underruns the allowed minimum length of '2'. Element '{http://www.portalfiscal.inf.br/nfe}xBairro': '0' is not a valid value of the local atomic type.


Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Logix) - Nota Fiscal Eletrônica (NFE) - Versão 12

Causa
A mensagem de erro de SCHEMA está indicando que a TAG xBairro está com tamanho inferior ao mínimo permitido, sendo que o tamanho mínimo é 2.

Veja um exemplo de informação incorreta nessa TAG no XML da nota fiscal:
<xBairro>0</xBairro>

Então essa mensagem de erro ocorre porque o bairro não foi informado, ou está com informação incorreta no cadastro do cliente da nota fiscal ou do emitente da nota fiscal. No exemplo, o campo bairro está com a informação 0 - zero no cadastro.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Consulte no VDP10000 - Cadastro de Cliente o cliente informado nessa nota fiscal, verifique se o campo Bairro está correto. Caso não estiver modifique e informe corretamente.

2. Se o cliente estiver com o bairro informado corretamente consulte o código de cliente utilizado como emitente da nota fiscal, e verifique o campo Bairro.

3. É possível saber se o problema é no cliente da nota fiscal ou no emitente verificando em qual grupo do XML está a TAG com a informação incorreta:

xBairro no grupo emit é o bairro do emitente da nota fiscal.
xBairro no grupo dest é o bairro do destinatário da nota fiscal.

4. Essa informação é obrigatória para a SEFAZ, então o campo não pode ficar em branco ou com 0 - zero. Caso não existir nome de bairro no endereço, uma sugestão seria informar o nome da cidade como bairro.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _