Tempo aproximado para leitura: 00:02:10 min
Ocorrência
Ao realizar o cancelamento do item do pedido de venda é apresentada a mensagem de erro 5655 - Este Item está alocado para um embarque e não permite realizar o cancelamento do item do pedido.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Pedidos de Vendas (MPD) - Todas as versões.
Causa
A mensagem de erro é apresentada pois há alocações pendentes de faturamento para este item e o cancelamento do item será permitido apenas quando não existir itens alocados.
Solução
Para realizar o cancelamento do item do pedido será necessário verificar as alocações existentes para o mesmo. A consulta dos embarques que foram criados e vinculados no pedido poderá ser realizada no programa PD1001A - Consulta Relacionamento Pedidos.
Posicione no pedido e vá na pasta Embarq. Quando o pedido está com um embarque ou mais com a situação de Alocado, não será permitido realizar o cancelamento do item, sem que antes seja realizada a desalocação do item no programa EQ0506 - Preparação Faturamento.
Na consulta do item será possível verificar que há alocações para o item, no campo QT Alocada.
A alocação do item poderá ser visualizada também no programa EQ1007 - Consulta Embarques do Item, utilizando o botão de seleção e de parâmetros para posicionar no pedido alocado. Na seleção informe o nome abreviado do cliente e a data de entrega, caso seja um pedido antigo, lembre-se de alterar a data de entrega inicial. No botão parâmetros marque apenas alocados.
Caso não localize nenhum embarque com a situação de Alocado na consulta do pedido ou ainda no programa EQ1007, execute o programa especial spp/pdp/sppd309.r para atualizar a quantidade alocada no item do pedido e assim permitir realizar o cancelamento.
Informe na pasta Seleção o Nome abreviado do cliente e o numero do pedido do cliente. Utilize sempre a opção pedido, não recomendamos o uso da opção período.
0 Comentários