Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS- PDV -  Erro no método InserirMovimentoPagamento do WS PDV Padrão

 

Ocorrência
No Web Service PDV Padrão na chamada do método InserirMovimentoPagamento  é apresentado erro conforme descrito abaixo, e os movimentos do PDV não integram no RMS

 

 == Classe: MovimentoDAO Metodo: InserirMovimentoPagamento RefMSG: ERRO *** DescMSG: ORA-12899: valor muito grande para a coluna "RMSTESTE"."DETCUPOMP1"."DETP_DESCR_PGTO" (real: 25, máximo:

 


Ambiente

 TOTVS Varejo Supermercados (Linha RMS) - PDV - Todas as versões

Causa

Esse incidente ocorre, devido a estouro de campo na TAG DescriçãoFinalizadora, uma vez que a mesma só aceita no máximo 20 caracteres
Solução

Para solucionar essa ocorrência, realize os seguintes passos:

 

 

Verificar no XML enviado se o campo DescriçãoFinalizadoraestá com mais de 20 caracteres e orientar o cliente a entrar em contato com o suporte do seu PDV para ajuste conforme manual abaixo;

 

https://tdn.totvs.com/display/public/LRMS/Manual+do+Webservice+CRM%2C+PDV+e+Vendas+Assistidas

 

 



Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _