FAQs - Suporte técnico

Framework - Linha RM - Frame - Formatação condicional não foi aplicada à coluna selecionada

time.pngTempo aproximado para leitura: 00:04:00 min
Ocorrência
Ao configurar formatação condicional a aparência da formatação não é aplicada à coluna, como corrigir?


Ambiente
Framework - Linha RM - Frame - Todas as versões


Causa
A validação para formatação condicional considera os espaços em branco no valor a ser comparado e diferencia letras maiúscula e minúscula. Sendo assim, o valor da coluna a ser aplicada a aparência da formatação condicional deverá ser exatamente o mesmo valor parametrizado na formatação, considerando espaços em branco e letras maiúscula e minúscula. 

 

Solução
No exemplo abaixo temos a formatação condicional para a coluna Código de Acesso aplicada no cadastro de usuários em Serviços Globais | Segurança | Usuário:

mceclip2.png 

mceclip3.png

O valor parametrizado na formatação condicional é exatamente o mesmo indicado na coluna Código de Acesso, sendo assim, a formatação foi aplicada com sucesso. No exemplo abaixo temos um exemplo de formatação diferenciando espaço em branco:

mceclip0.png

mceclip1.png

No caso acima a formatação não foi aplicada pois na coluna Código de Acesso o valor não possui espaço em branco no final e na formatação condicional foi inserido espaço em branco, como o sistema valida todo o valor inserido, a formatação não foi aplicada.

O valor a ser configurado deve ser o mesmo que está cadastrado na tabela. Valide se na tabela possui também espaçamentos. 

 

Importante

Para mais detalhes sobre como utilizar a formatação condicional acesse: RM - Frame - Como utilizar recurso de formatação condicional na visão

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _