Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha RM - Frame - Formatação condicional não foi aplicada à coluna selecionada

time.png Tempo aproximado para leitura: 00:05:40 min

Ocorrência
Ao configurar formatação condicional a aparência da formatação não é aplicada à coluna, como corrigir?


Ambiente
Framework - Linha RM - Frame - Todas as versões


Causa
A validação para formatação condicional considera os espaços em branco no valor a ser comparado e diferencia letras maiúscula e minúscula. Sendo assim, o valor da coluna a ser aplicada a aparência da formatação condicional deverá ser exatamente o mesmo valor parametrizado na formatação, considerando espaços em branco e letras maiúscula e minúscula. 
Além disso, o valor cadastrado no campo valor deve ser idêntico ao gravado na tabela, no banco de dados. Alguns campos no banco de dados são gravados com os valores de constantes do aplicativo. 

 

Solução
No exemplo 1 abaixo temos a formatação condicional para a coluna Código de Acesso aplicada no cadastro de usuários em Serviços Globais, Segurança, Usuário:



 

O valor parametrizado na formatação condicional é exatamente o mesmo indicado na coluna Código de Acesso, sendo assim, a formatação foi aplicada com sucesso. No exemplo abaixo temos um exemplo de formatação diferenciando espaço em branco:





No caso acima a formatação não foi aplicada pois na coluna Código de Acesso o valor não possui espaço em branco no final e na formatação condicional foi inserido espaço em branco, como o sistema valida todo o valor inserido, a formatação não foi aplicada.

O valor a ser configurado deve ser o mesmo que está cadastrado na tabela. Valide se na tabela possui também espaçamentos. 

No exemplo 2 abaixo, foi aplicada a formatação condicional para o campo Status Cnab na tela de lançamentos financeiros (BackOffice, Gestão Financeira, Contas a pagar/Receber, Lançamento), entretanto não funciona:



Para que a formatação condicional seja aplicada corretamente, faz-se necessário que o valor informado no campo seja idêntico ao cadastrado na base de dados. Para o campo Status Cnab são utilizadas constantes, por exemplo, para que considere o valor Não Remetido, deve ser informado o valor da constante = 0:



O valor a ser configurado deve ser o mesmo que está cadastrado na tabela. Para campos que utilizam constantes, validar junto ao suporte do produto os valores das constantes, neste exemplo:

  • 0 -  Não Remetido
  • 1 -  Remetido
  • 2 -  Registrado
  • 3 -  Recusado
  • 4 -  Baixado
  • 5 -  Registrado Online
  • 6 -  Cancelado
  • 7 -  Pendente Remessa
  • 8 -  Pendente Autorização


Abaixo seguem links de constantes utilizadas por alguns aplicativos:

FIN - Constantes do Financeiro

TOTVS Gestão de Estoques - Constantes

 

Saiba mais

Para mais detalhes sobre como utilizar a formatação condicional acesse o link abaixo:

Framework - Linha RM - Frame - Como utilizar recurso de formatação condicional na visão

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _