Ocorrência
Ao salvar o Pedido de Venda ocorre Help A410NATBLK.
Ambiente
Cross Segmentos - Backoffice Protheus - SIGAFAT - Todas as versões
Causa
Indica que foi configurado (nos parâmetros MV_1DUPNAT / MV_2DUPNAT) para considerar a Natureza do Cadastro do Cliente/Fornecedor de acordo com o Tipo de Pedido (C5_TIPO).
Porém, a Natureza preenchida está bloqueada (inativo), conforme informação do Help de tela. É necessário utilizar uma natureza que esteja ativa.
Solução
Realize a seguinte verificação:
1. Se for uma nota de diferente de "Devolução" ou "Beneficiamento":
- Avalie o Conteúdo do parâmetro MV_1DUPNAT
- Se estiver apontando para SA1->A1_NATUREZ, verifique a Natureza preenchida neste campo, no Cadastro do Cliente (CRMA980);
- Se estiver apontando para SC5->C5_NATUREZ, verifique a Natureza preenchida neste campo, no cabeçalho do Pedido de Vendas (MATA410);
2. Se fo uma nota de "Devolução" ou "Beneficiamento"
- Avalie o Conteúdo do parâmetro MV_2DUPNAT
- Se estiver apontando para SA2->A2_NATUREZ, verifique a Natureza preenchida neste campo, no Cadastro do Fornecedor;
- Se estiver apontando para SC5->C5_NATUREZ, verifique a Natureza preenchida neste campo, no cabeçalho do Pedido de Vendas (MATA410);
Ao identificar a Natureza que o sistema esta utilizando, verifique se a mesma se encontra bloqueada para uso em seu cadastro.
Desbloqueando a Natureza ou mudando ela, o sistema deixará de apresentar o help.
Saiba mais:
FAT0038_A410NATVZO_A410NATUSO_A410NATCLI_A410NATPED_ A410NATBLK _ no Pedido de Vendas (MATA410)
0 Comentários