FAQs - Suporte técnico

Cross Segmentos - Backoffice Protheus - Arq. Magnéticos - DIME - Erro de validação: Registro 84 - Declaração complementar anual indevida para o período



time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Registro 84
gerado indevidamente no arquivo txt o que ocasiona o seguinte erro de validação: Registro 84 - Declaração complementar anual indevida 

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - A partir da versão 12.1.25.

Causa
Esse incidente ocorre, pois a terceira wizard de geração do arquivo, referente aos quadros 80/90 está com dados preenchidos nos campos.

 

Solução
Para solucionar essa ocorrência, a wizard abaixo não pode estar preenchida com dados.

 

 

mceclip1.png

 

Caso esteja preenchida, o sistema pega os valores da wizard do registro 84, mesmo que zerados. 

Para não gerar o registro, a wizard acima não deve ser preenchida.

Trecho do fonte: 

If !Empty (AllTrim (aWizard[3][3]))
  //
  //Pro-labore
  AtuVlrDime(, "84", "84", "411", Val (aWizard[7][1]), 2)


...


//Totalizador
  For nI :=1 To Len (aWizard[7])
      nTotal    +=    Val (aWizard[7][nI])
  Next (nI)
  //
  //Total
  AtuVlrDime(, "84", "84", "499", nTotal, 2)

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _