Tempo aproximado para leitura: 00:03:00 min
Ocorrência
Planejamentos não conseguem ser publicados.
Ambiente
Cross Segmentos - TOTVS CRM Gestão de Clientes - Planejamento - Todas as versões
Causa
Um dos principais motivos é a duplicidade de dados.
Solução
Para solucionar essa ocorrência e assim publicar seu planejamento, realize os seguintes passos:
1. Verifique como está sendo realizada a consulta nos datasets:

2. Cada consulta criada deve possuir um campo único que identifique cada linha, isso para que não haja duplicidades. Este campo pode ser dois ids concatenados, por exemplo.

3. Caso o dataset já possua um campo identificador, faça também uma busca por: somente registros distintos.

4. Caso o dataset possua vínculos, verifique se o dataset possui uma coluna que faça essa ligação externa:

5. Nessa etapa, execute o job e aguarde o retorno de sucesso.


6. Se possível, republique o planejamento. Para republicar o planejamento é necessário ter acesso ao banco do tenant.

Observação: Caso não tenha acesso ao banco verificar com o time de Produto.
Artigos relacionados:
0 Comentários