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WINT - Rejeição 217: NF-e não consta na base de dados da SEFAZ na rotina 1477

Ocorrência

Ao tentar enviar uma Carta de Correção Eletrônica na rotina 1477 - Emissão da Carta de Correção Eletrônica, é apresentada a rejeição 217: NF-e não consta na base de dados da SEFAZ

Ambiente
TOTVS Distribuição Linha Winthor - 14 - Faturamento -  A partir da versão 30

Causa

Essa rejeição ocorre quando é feita a consulta de uma nota que ainda não foi autorizada ou é inexistente na Sefaz Estadual, ou se a nota foi consultada no ambiente errado. Neste caso, será retornada a "Rejeição 217 - NF-e não consta na base de dados da SEFAZ".

Exemplo:

Quando uma nota ainda não foi autorizada e a chave de acesso é consultada ou quando a nota foi emitida em um ambiente de homologação e consultada em ambiente de produção e vice-versa.

Regra de validação da sefaz:

mceclip0.png

 

Solução

Para resolver a mensagem consulte a chave de acesso da NF-e em questão no portal nacional da SEFAZ ou no portal estadual da SEFAZ. Caso não encontrada no portal nacional consulte também no portal estadual.

Com o resultado da consulta em mãos, podemos seguir por dois caminhos:

  • Com a NF-e autorizada na SEFAZ, muito provavelmente a consulta está sendo executada no ambiente errado, a nota está autorizada no ambiente de produção enquanto a consulta está no ambiente de homologação. Logo a solução é verificar o porquê dessa diferença.
  • Com a NF-e não autorizada na SEFAZ, isso pode significar que a NF-e pode não ter sido emitida ou ainda não foi sincronizada junto a SEFAZ de origem. Também pode ocorrer dos servidores da SEFAZ estarem passando por problemas e no momento da consulta a rejeição está ocorrendo e nesse caso vai ser preciso aguardar a normalização do serviço.
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