Ocorrência
Ao tentar efetuar o Fechamento de Período, através da rotina GPEM120, gera error log: "array out of bounds ( 0 of 0 ) on GP120FECFOL(GPEM120.PRX)"
Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - Todas as versões
Causa
O erro ocorre devido ao sistema não conseguir reconhecer o período/roteiro ao efetuar o fechamento e demonstrar a mensagem com o log da falta dos Turnos no Cadastro de Calendário
Solução
Para que o log seja apresentado no lugar do erro, necessário atualizar o fonte GPEM120 com data à partir de 23/03/2022 com o pacote de Expedição Contínua do RH abaixo:
Pacote de expedição contínua do RH: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854
Ao demonstrar a mensagem dos Turnos que não possuem calendário cadastrados, necessário efetuar os procedimentos abaixo:
1. Acesse a Rotina no Módulo de Gestão de Pessoal, em Atualizações/Definições de Cálculo/Períodos;
2. Acesse o Processo e Período que está tentando Fechar e clique em "Alterar";
3. Verifique na Aba "Cadastro de Calendário" se existe corretamente um Calendário para cada Turno existente em seu ambiente e/ou uma linha com o Conteúdo de Calendário "padrão", para o Turno "@@@", como demonstrado abaixo como exemplo:
Informações complementares
Documentação da solução: https://tdn.totvs.com/pages/releaseview.action?pageId=676582107
Pacote de Expedição Contínua do eSocial: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854
Pacote de Expedição Contínua do Medicina e Segurança do Trabalho: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057956773
0 Comentários