Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - array out of bounds ( 0 of 80 ) on A410INCREM(FISXFUN.PRX)


time.png Tempo aproximado para leitura: 00:02:00min

Ocorrência

Ao clicar em outras ações, Amarração de NFS no pedido de vendas, gera o erro: array out of bounds ( 0 of 80 )  on A410INCREM(FISXFUN.PRX)

Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT- Todas as versões

Causa
Erro de array out of bounds ocorre quando um campo do array não existe no dicionário de dados, ou não está marcado o uso ou mudou o nível do campo.

A rotina A410INCREM está verificando se há integração com o projeto PMS e se os campos abaixo não estão vazios:

C6_PROJPMS
C6_EDTPMS
C6_TASKPMS

Desta forma, é necessário validar se os campos existem no dicionário de dados, configurador, tabela SC6, se estão marcados como usado e se estão com o nível igual a 1.


Solução

Para solucionar essa ocorrência, realize os seguintes passos:


1. Via configurador, dicionário de dados, tabela SC6, valide se os campos C6_PROJPMS, C6_EDTPMS e
C6_TASKPMS
existem na tabela, se estão marcados como usado e se estão com nível igual a  1.

2. Caso não estejam, efetue a marcação dos campos como usado e deixe o nível igual a 1, salve o campo, salve a tabela sc6, atualize o dicionário de dados, reinicie o smartclient e efetue o processo novamente.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _