Tempo aproximado para leitura: 00:02:00min
Ocorrência
Ao clicar em outras ações, Amarração de NFS no pedido de vendas, gera o erro: array out of bounds ( 0 of 80 ) on A410INCREM(FISXFUN.PRX)
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT- Todas as versões
Causa
Erro de array out of bounds ocorre quando um campo do array não existe no dicionário de dados, ou não está marcado o uso ou mudou o nível do campo.
A rotina A410INCREM está verificando se há integração com o projeto PMS e se os campos abaixo não estão vazios:
C6_PROJPMS
C6_EDTPMS
C6_TASKPMS
Desta forma, é necessário validar se os campos existem no dicionário de dados, configurador, tabela SC6, se estão marcados como usado e se estão com o nível igual a 1.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Via configurador, dicionário de dados, tabela SC6, valide se os campos C6_PROJPMS, C6_EDTPMS e
C6_TASKPMS existem na tabela, se estão marcados como usado e se estão com nível igual a 1.
2. Caso não estejam, efetue a marcação dos campos como usado e deixe o nível igual a 1, salve o campo, salve a tabela sc6, atualize o dicionário de dados, reinicie o smartclient e efetue o processo novamente.
0 Comentários