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Ocorrência
O Painel E-social apresenta erros ao tentar configura-lo ou quando tento acessar a rotina.
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Automação Fiscal (SIGATAF) – TAF- Painel E-social (TAFA552A)
Causa
Os incidente costumam ocorrer pela falta de algumas configurações obrigatórias, ou configuração errada do Painel E-social.
Solução
Independente do erro que venha a apresentar o Painel E-social, seja na configuração ou após a instalação, quando acessar a rotina, orientamos que seja avaliado as informações do passo a passo que vamos apresentar.
1. Pré-requisitos para configuração do Painel E-social:
Verifique em seu ambiente se os pré-requisitos para correto funcionamento do Painel E-social foram atendidos.
- Binário atualizado Lobo Guará (LG).
Appserver: https://suporte.totvs.com/portal/p/10098/download#detail/947528
Smartclient: https://suporte.totvs.com/portal/p/10098/download?e=947510
Como atualizar o appserver e o smartclient:
https://tdn.totvs.com/pages/releaseview.action?pageId=224123650
- Ambiente atualizado com o último acumulado, incluindo o menu, para que a opção “Painel E-social” fique disponível.
Como atualizar o TAF:
Automação Fiscal - Atualização - Expedição contínua no TAF (eSocial)
- Possuir um serviço HTTP configurado.
Como configurar um serviço HTTP:
Acrescente a seção [HTTP] no appserver.ini onde o Painel E-social será configurado, essa seção precisa ser exclusiva para o Painel E-social.
Se já possuir serviços configurados, como por exemplo o serviço do Meu RH, a porta HTTP pode ser a mesma, sendo necessário ajustes na seção [HTTP]:
- Migre as configurações da sessão HTTP para uma sessão com IP e Porta.
- Inclua as configurações do Painel E-social na sessão HTTP.
Conforme o exemplo abaixo:
Apenas o Meu RH:
Meu RH e Painel E-social:
- Possuir um serviço REST configurado.
Atenção: Clientes, que já possuirem a Porta Multi-Protocolo (MPP) ativada, a criação do
serviço REST não é necessária.
Como configurar um serviço REST:
A porta utilizada para o serviço REST, precisa ser exclusiva para o Painel E-social.
Acrescente as seções que listamos abaixo no appserver.ini onde o Painel E-social será configurado:
IMPORTANTE:
Orientamos criar um appserver.ini separado para o Painel E-social.
Clientes Cloud (T-Cloud) do TOTVS, precisam solicitar a configuração do Painel E-social á área do CLoud:
Automação Fiscal - Como solicitar suporte TOTVS para o produto, TSS ou Cloud
2. Como criar um appserver.ini separado da aplicação, exclusivo para os serviços do Painel E-social:
Entre na raiz de instalação do Protheus, copie a pasta "appserver", renomeie a pasta copiada:
Abra para edição o arquivo appserver.ini localizado dentro da pasta copiada, será o appserver.ini para os serviços do Painel E-social.
- Altere o nome do Ambiente (ENVIRONMENT);
- Altere o numero da porta TCP;
- Pode ser mantido o direcionamento para o rpo da aplicação, desta forma, somente um rpo precisa ser atualizado;
- Exclua todos os serviços desnecessários para o Painel E-social, como Schedule, Help, WS, app, etc.;
- Certifique-se de deixar a estrutura necessária para o correto funcionamento do Painel E-social.
**Utilize as portas que liberou para os serviços HTTP ([HTTP]), REST ([HTTPREST])e as configurações do seu ambiente;
**Abaixo somente o trecho do appserver.ini referente ao Painel E-social;
Pontos de Atenção:
- Verifique se o caminho na chave RootPath no grupo [ENVIRONMENT] está apontando para o “rpo” correto;
- Verifique se o caminho na chave PATH no grupo [HTTP] está apontando para a pasta “http-root”;
- Se possuir a chave PrepareIn dentro do grupo [HTTPURI] mantenha a chave comentada;
- A chave PrepareIn dentro do grupo [TAF_CFGJOB], mantenha como ALL, pois dessa forma, o sistema vai ler todos os grupos de empresa;
- Certifique-se que a chave JOBS dentro do grupo [TAF_CFGJOB] contém os dois Jobs: HTTPJOB e TAF_CFGJOB
3. Acesse o menu Painel E-social:
Pelo menu principal do TAF: Atualizações > Eventos Esocial > Painel E-social
Ao acessar a rotina Painel E-social pela primeira vez, a pasta http-root será criada dentro da pasta Protheus Data, onde ficará armazenado os artefatos da rotina.
Não é possível fazer download dos artefatos, eles são criados ao acessar a rotina.
4. Configure os parâmetros do Painel E-social:
Pelo configurador (SIGACFG) verifique se os parâmetros abaixo foram criados:
- MV_BACKEND – Receberá no campo conteúdo a URL do serviço REST (http://IP:PORTAREST/rest)
- MV_GCTPURL – Receberá no campo conteúdo a URL do serviço HTTP (http://SEUIP:PORTAHTTP)
- MV_TAFPO – Informará se possui mais módulos do Protheus, deixando o campo conteúdo com .T. em caso positivo ou .F., caso não possua;
Caso não possua um ou mais parâmetros, os mesmos podem ser criados pelo configurador:
Segue exemplos para conferir e criar os parâmetros:
MV_BACKEND:
MV_GCTPURL:
MV_TAFPO:
Pontos de Atenção:
Insira nos parâmetros MV_BACKEND (REST) e MV_GCTPURL (HTTP) as portas liberadas para os respectivos serviços REST e HTTP, as mesmas que inseriu no appserver.ini onde o Painel E-social foi configurado.
Exemplo:
REST: http://localhost:8080/rest
HTTP: http://192.168.15.26:8083
5. Teste as URL´s dos serviços HTTP e REST:
Como testar:
HTTP:
Pelo navegador de internet que utiliza, digitar o endereço HTTP (URL) que está no parâmetro MV_GCTPURL, após a URL do parâmetro, insira /time.apl
Se não existir bloqueios de Firewall, antivírus, ou na VPN, será apresentado o horário atual.
REST:
Pelo navegador de internet que utiliza, digitar o endereço REST (URL) que está no parâmetro MV_BACKEND;
Será aberta uma página com informações das API´s (Application-Programming Interface, ou Interface de Programação de Aplicação).
6. Se o erro na rotina do Painel E-social persistir:
Abra um ticket para o suporte TOTVS TAF Esocial, e anexe as informações abaixo:
- Descrição do momento que o erro ocorre;
- Print do erro;
- Cópia do arquivo appserver.ini onde o Painel E-social está configurado;
- Print ou a tabela SX6 com os parâmetros: MV_BACKEND, MV_GCTPURL e MV_TAFPO;
- Habilite a chave fwlogmsg_debug=1 no arquivo appserver.ini dentro do grupo [ENVIRONMENT] (ambiente);
- Após habilitar, renomeie o console.log existente. Gere o erro no Painel E-social, e encaminhe para o suporte o novo arquivo console.log
Saiba Mais:
Consulte nossas FAQ´s:
TAF - ATUALIZAÇÃO - Como configurar o TAF do Futuro
TAF - CONFIGURAÇÃO - Erro ao abrir o TAF do Futuro
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