Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice (Linha Protheus) - Faturamento - array out of bounds ( 0 of 120 ) on MA410IMPOS(MATN410B.PRW)

Ocorrência

Ao acessar a planilha financeira, gera o erro: array out of bounds ( 0 of 120 )  on MA410IMPOS(MATN410B.PRW) 11/12/2020 15:20:00 line : 614

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Faturamento - Todas as versões

Causa
O erro de array out of bounds significa que está sendo procurado um campo utilizado no array que não existe no dicionário, ou não está marcado para uso ou teve seu nível de campo mudado.

Neste caso o sistema está tentado encontrar o campo c6_clasfis que alimentará o array aCols[nX,nPClasFis e não está encontrando, gerando o erro em questão.


Solução

Para solucionar essa ocorrência, realize os seguintes passos:


1. Via configurador, dicionário de dados, tabela SC6, valide se o campo C6_CLASFIS existe na tabela, se está marcado como usado e se está com nível igual a  1. Caso não esteja, efetue a marcação do campo como usado e deixe o nível igual a 1, salve o campo, salve a tabela sc6, atualize o dicionário de dados, reinicie o smartclient e efetue o processo novamente.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _