FAQs - Suporte técnico

TOTVS Construção - Obras e Projetos - TCOP - Campo C7_APROPRM não existe no dicionário de dados na tabela SX3

Ocorrência
No módulo Obras e Projetos, ao tentar realizar o processo de buscar apropriação do backoffice é apresentada a mensagem Campo 'C7_APROPRM' não existe no dicionário de dados na tabela 'SX3'.

Ambiente
Totvs Construção - Obras e Projetos - Todas as versões integradas com EAI 2.0

Causa
Esse incidente ocorre, pois não existe o campo C7_APROPRM na tabela SC7 do dicionário de dados SX3 do Protheus.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Execute o configurador do Protheus através do Programa inicial SIGACFG;
mceclip0.png
2. Acesse a opção Base de Dados através da opção de menu Base de Dados - Dicionário - Base de Dados;
mceclip14.png

3. Posicione no menu à esquerda em Dicionário de Dados e clique na Lupa para habilitar o campo de pesquisa;
mceclip1.png

4. Realize a procura por SC7 e pressione Buscar;
mceclip2.png

5. Posicione na linha com prefixo SC7 e clique no botão de Editar;
mceclip3.png

6. Clique no sinal de (+) para expandir a pasta Ped. compra / Aut entrega e clique na opção Campos;
mceclip4.png

7. Crie o novo campo a partir do botão Incluir;
mceclip5.png

8. Informe no campo o conteúdo C7_APROPRM, com tipo 1 - Caracter e tamanho 1;
mceclip6.png

9. Na aba Informações preencha os títulos, pois, são campos obrigatórios, em seguida preencha as descrições do campo e clique em Salvar;
mceclip8.png

10. Clique no botão Confirmar;
mceclip9.png

11. Será preciso atualizar a base de dados do Protheus para inclusão do novo campo, e para isso utilize o botão Atualizar Base de Dados;
mceclip10.png

12. Clique em Avançar na tela de Atualização da Dicionário de Dados;
mceclip11.png

13. Novamente você deve Avançar para iniciar a atualização;
mceclip12.png

14. Finalize a atualização do Dicionário de Dados;
mceclip13.png

15. Reinicie o serviço do Webservice referente ao EAI do Protheus;

16. Realize novamente o processo de buscar Apropriação do BackOffice a partir do módulo Obras e Projetos do RM

 

Importante
Este processo deverá ser realizado pelo administrador do ambiente Protheus devido a necessidade de acesso ao configurador.

A inclusão desse campo deverá ser realizado para cada grupo de empresas do Protheus que esteja integrado com a RM.

O processo de atualização do dicionário de dados deverá ser realizado em modo exclusivo.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _