Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Varejo Supermercados - Gerencial - Análise ABC Venda Distribuição - ORA-01858

Ocorrência
Ao realizar a busca da informação ocorre a seguinte mensagem: ORA01858: foi localizado um caractere não numérico onde se esperava um numérico.

mceclip0.png

Ambiente
Varejo Supermercados - Gerencial - Análise ABC Venda Distribuição - Todas as versões.

Causa
Esse incidente ocorre, pois a parametrização do Oracle Client está fora do padrão de instalação recomendado.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Abra o editor de registro do Windows, Regedit.

2. Localize a chave abaixo conforme a versão do Windows (32-bit ou 64-bit) e do home instalado:

Win 64bits – HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ORACLE\KEY_OraClient11g_home1
Win 32bits – HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE\KEY_OraClient11g_home1

3. Altere o valor da chave NLS_LANG para AMERICAN_AMERICA.WE8ISO8859P1

Importante: Para maiores detalhes sobre instalação do Oracle Client Clique Aqui. 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _