Ocorrência
Após a atualização para a V12R31, não é possível congelar alguns inventários. O sistema esta criticando produtos que são receita, desta forma, não consegue fazer o congelamento dos inventários.

Ambiente
Totvs Varejo Supermercados Linha RMS - Todas as versões
Causa
Neste caso não pode congelar inventário com empenhos em aberto.
Provavelmente a agenda de componentes e receitas está configurada para empenhar estoque = Não.
Entretanto, esta agenda empenha o estoque até a próximo importação da venda, pois, é durante a importação da venda que é gerada a nota destes empenhos das agendas de componentes e receitas. Ou seja, esta agenda deveria estar configurada como empenha estoque = SIM
Por causa desta configuração ANTES o inventário não pegava estes empenhos.. e poderia acarretar PROBLEMAS DE ESTOQUE NO FUTURO...
Solução
Para sanar isso, foi considerado durante o congelamento as agendas de componentes e receitas independente se a configuração esta para empenhar estoque ou não, pois, como a mesma empenha o sistema passou a ignorar esta informação para ser mais assertivo.
Neste contexto, para que estes empenhos desapareçam é preciso que a venda seja importada.. ou seja: Se movimentou a receita não é possível congelar o inventário até que a venda seja importada.
Logo é preciso que o inventário seja congelado após a importação de venda e que não tenha nenhum item do inventário empenhado.
A orientação NÃO é alterar as agendas, pois não fará diferença, a crítica não é porque está com "Empenha Estoque = N", mas sim porque tem estoque empenhado, então alterar a configuração não vai alterar o resultado, vai continuar ocorrendo a crítica.
Portanto não é necessário alterar as agendas.
Desde o princípio os clientes congelaram os inventários com empenhos destas agendas em aberto e logo após a próxima importação de venda aparecia DIFERENÇA NO ESTOQUE, ou seja, esta parametrização como empenha estoque NÃO dará PROBLEMAS DE ESTOQUE.
Isso foi percebido e corrigido em análises no Projeto do Estoque realizados este ano.
O que foi feito para corrigir a situação e evitar o problema de estoque:
1 - No congelamento o sistema passou a olhar estas agendas de componentes e receitas com o empenha estoque Não.
E assim os clientes que tiverem movimentado qualquer receita não irão congelar os componentes, já que estes empenhos estão em aberto em pedidos na tabela do faturamento on-line.
Para que estes itens sejam congelados é preciso que estas notas de empenhos de receitas e componentes sejam geradas.. e este tipo de nota somente é gerada após a importação da venda, desde o principio, isso não foi alterado.
Outro princípio do inventário é que somente é possível congelar o inventário se não tiver nenhum empenho em aberto ou seja, nenhum pedido que foi foi criado e ainda não foi faturado. Neste contexto, os cliente não iram conseguir congelar inventário se tiverem movimentado qualquer receita antes, e somente será possível se após a importação da venda não for movimentada nenhuma receita.
OBS: CASO O CLIENTE AINDA ASSIM DESEJE QUE SEJA REALIZADO O CONGELAMENTO DO INVENTÁRIO COM ESTES ITENS DE PRODUÇÃO/RECEITAS EM ABERTO, O MESMO DEVERÁ REALIZAR A SOLICITAÇÃO VIA CENTRAL COLABORATIVA E ASSUMINDO ASSIM, OS POSSÍVEIS PROBLEMAS DE ESTOQUE QUE OCORRERÁ.
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