Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS - REC - Cancelamento de nota Nota Fiscal com Romaneio em Aberto. Processo Cancelado. Utilizar reprocessamento do Mapa.

Ocorrência

Problema ao cancelar nota 'VGRMMENU' 

 

Nota Fiscal com Romaneio em Aberto. Processo Cancelado. Utilizar reprocessamento do Mapa. AG1PICKL, AG4CGFAT - 0.

 

problemaaocancelarnota.PNG

 

Ambiente
Retail Manager System,  V12R27, V12R31, V12R32.

Causa
Mesmo com a nota rejeitada o seu romaneio consta em aberto.

Solução


Para solucionar essa ocorrência, realize os seguintes passos:

1. Se faz necessário verificar nas tabelas  AG1PICKL, AG4CGFAT, caso a consulta retorne zerada se faz necessário seguir os passos abaixo:


2.  Realizar a seguinte consulta no 'PL/SQL'  select * from AA1CFISC consultar esse campo fis_pedido_2  correspondente a nota.

Exemplo imagem abaixo:  para a verifiquei a nota que e procurei o campo fis_pedido_2 que foi 2964709

fis_pedido.PNG

 


3 -. Realizo a consulta com o FIS_PEDIDO_2 que foi 2964709.

 

select * from AG1PICKL pickl, AG4CGFAT cgfat
where pickl.pln_numero_1 = 2964709 
 and cgfat.gfx_romaneio_1 = pickl.pln_numero_1;

 

4- Assim que a consulta retornar os dados,  vai necessário realizar o delete de acordo ao comando abaixo:

delete from AG1PICKL where pickl.pln_numero_1 = 2964709;

delete from AG4CGFAT where gfx_romaneio_1 = 2964709;

 

5- Após isso realizar novamente a consulta do passo 3 para verificar se os dados foram apagados, neste caso deve ir no programa ' VGRMMENU' e refazer o processo de cancelamento de nota.

 

confirmocan.PNG

 

Atenção: Esse processo só deve ser feito para o problema relatado nesta documentação  'Nota Fiscal com Romaneio em Aberto. Processo Cancelado. Utilizar reprocessamento do Mapa. AG1PICKL, AG4CGFAT'.

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _