Ocorrência
Problema ao cancelar nota 'VGRMMENU'
Nota Fiscal com Romaneio em Aberto. Processo Cancelado. Utilizar reprocessamento do Mapa. AG1PICKL, AG4CGFAT - 0.
Ambiente
Retail Manager System, V12R27, V12R31, V12R32.
Causa
Mesmo com a nota rejeitada o seu romaneio consta em aberto.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Se faz necessário verificar nas tabelas AG1PICKL, AG4CGFAT, caso a consulta retorne zerada se faz necessário seguir os passos abaixo:
2. Realizar a seguinte consulta no 'PL/SQL' select * from AA1CFISC consultar esse campo fis_pedido_2 correspondente a nota.
Exemplo imagem abaixo: para a verifiquei a nota que e procurei o campo fis_pedido_2 que foi 2964709
3 -. Realizo a consulta com o FIS_PEDIDO_2 que foi 2964709.
select * from AG1PICKL pickl, AG4CGFAT cgfat
where pickl.pln_numero_1 = 2964709
and cgfat.gfx_romaneio_1 = pickl.pln_numero_1;
4- Assim que a consulta retornar os dados, vai necessário realizar o delete de acordo ao comando abaixo:
delete from AG1PICKL where pickl.pln_numero_1 = 2964709;
delete from AG4CGFAT where gfx_romaneio_1 = 2964709;
5- Após isso realizar novamente a consulta do passo 3 para verificar se os dados foram apagados, neste caso deve ir no programa ' VGRMMENU' e refazer o processo de cancelamento de nota.
Atenção: Esse processo só deve ser feito para o problema relatado nesta documentação 'Nota Fiscal com Romaneio em Aberto. Processo Cancelado. Utilizar reprocessamento do Mapa. AG1PICKL, AG4CGFAT'.
0 Comentários