Tempo aproximado para leitura: 00:10:00 min
Ocorrência
Ao realizar a emissão de NFC-e no PDV, a nota permanece em contingência e apresenta retorno semelhante aos exemplos abaixo:
Código retorno: 7
Retorno: 5 - Falha na validação dos dados da nota
Podendo ocorrer mensagens como:
Erro: Schema inválido --> 3004 - element decl. '{http://www.portalfiscal.inf.br/nfe}pOrig ', attribute 'type': The QName value...
5 - Falha na validação dos dados da nota: 3 --> 1839 - Element '{http://www.portalfiscal.inf.br/nfe}qrCode': [facet 'pattern'] The value 'https://www.sefaz.rs.gov.br/NFCE/NFCE-COM.aspx
Ambiente
TOTVS Varejo - Supermercados PDV - Linha Consinco - Aplicável para todas as versões.
Causa
Esse incidente ocorre porque a pasta “schemas” do PDV está desatualizada.
Com a atualização das regras da SEFAZ para NFC-e, novos campos e validações passam a ser exigidos.
Quando o PDV utiliza schemas antigos, o XML gerado não é validado corretamente conforme as regras atuais, ocasionando falha na validação e mantendo a NFC-e em contingência.
Solução
Para solucionar a ocorrência, é necessário atualizar a pasta “schemas” do PDV, acesse o Servidor de PDVs (Monitor) para executar o procedimento.
PDVs (Linux)
Passo 1. Para PDV Linux, acessar os arquivos pelo WinSCP até o seguinte local:
C5client/AcruxPDV/documento/nf-e
Observe a imagem abaixo no realce em vermelho.

Passo 2. Em seguida, na lateral esquerda, acessar o caminho da pasta 'schemas' no servidor de PDVs (Monitor):
C:\C5Client\AcruxMonitor\Services\documento\nf-e
Observe a imagem abaixo no realce em vermelho.

Passo 3. Copiar a pasta 'schemas', arrastando para o PDV para ser trocada. Observe a imagem abaixo no realce em vermelho. Muita atenção neste processo para ser copiada a pasta correta.
Passo 4. Logo após, reinicie a aplicação do PDV.
PDVs (Windows)
Passo 1. Em PDV Windows, acessar o caminho direto no PDV: C5client/AcruxPDV/documento/nf-e
Passo 2. Em seguida, acessar o caminho dentro do servidor de PDVs (Monitor):
C:\C5Client\AcruxMonitor\Services\documento\nf-e
Observe a imagem abaixo no realce em vermelho.
Passo 3. Copiar a pasta 'schemas' do servidor C:\C5Client\AcruxMonitor\Services\documento\nf-e e colar no PDV em questão, na pasta nf-e C:\C5client/AcruxPDV/documento/nf-e substituindo-a.
Muita atenção neste processo para ser copiada a pasta correta.
Passo 4. Logo após, reinicie a aplicação do PDV.
0 Comentários