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Prestadores de Serviços - SIGATEC - Help AT040FILOK1 na alteração da Base de Atendimento.

Ocorrência
Ao realizar a alteração de uma Base de Atendimento(TECA040) ocorre "Help: AT040FILOK1 " e não permite alteração.

mceclip0.png

Ambiente
Prestadores de Serviços - SIGATEC - A partir da versão 12.

Causa 
 

Pode ocorrer, pois o fonte TECA040 possui uma validação comparando a Filial que a Base de Atendimento foi cadastrada com a filial do cadastro do Produto. O sistema busca o B1_FILIAL (Cadastro de Produtos - MATA010) e compara com o AA3_FILORI (Cadastro de Base de Atendimento - TECA040) e valida a Filial que está tentando alterar o cadastro da Base.
O campo AA3_FILORI é preenchido automaticamente ao incluir o cadastro da Base de Atendimento, este é o registro da filial que está incluindo a base.


Solução
Na ocorrência do Help é necessário validar o preenchimento dos campos AA3_FILORI e B1_FILIAL verificando se estão devidamente preenchidos e se a base de atendimento tem como origem a filial que está realizando a alteração.

 

Obs.: Se o cadastro do produto é compartilhado o sistema não realiza esta comparação. No processo de Migração o fonte responsável pelo preenchimento do campo AA3_FILORI é o RUP_TEC, ocorrências relacionadas ao não preenchimento do campo podem ter sua origem na falta de atualização do fonte.

Para atualização, aplique o pacote de expedição contínua do módulo, conforme o release utilizado: SIGATEC

 

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