FAQs - Suporte técnico

RH - Linha Protheus - GPE - Erro ao efetuar busca pela consulta padrão - SRAXXX: SetOrder - Index not found. on { |O| (SELF:OBROWSE:CALIAS)->(DBSETORDER(SELF:OBROWSE:GETSEEK():GETORDER())),SELF:OBROWSE:UPDATETOPBOT( .F. ),SELF:OBROWSE:REFRESH(),SELF...


Ocorrência

Ao efetuar busca com a Consulta Padrão de Funcionários em várias rotinas, gera error log: "SRA020: SetOrder - Index not found. on { |O| (SELF:OBROWSE:CALIAS)->(DBSETORDER(SELF:OBROWSE:GETSEEK():GETORDER())),SELF:OBROWSE:UPDATETOPBOT( .F. ),SELF:OBROWSE:REFRESH(),SELF:CHANGESEEK(O) }(FWLOOKUP.PRW)"

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - Todas as versões

Causa
O erro ocorre por inconsistência na consulta padrão SRA

Solução
Para solucionar o problema será necessário verificar os itens abaixo:
1. Verifique em seu Configurador, logado na Empresa que o erro ocorre, a Consulta Padrão de nome SRA. Para isso:
-> Acesse o Módulo de Configurador;
-> Acesse a rotina Base de Dados/Dicionário/Bases de Dados;
-> Vá na opção "Consultas Padrão";
-> Busque pelo termo "SRA";
-> Clique sobre "Editar/Visualizar";
-> Nos demonstre todas as telas ao clicar em "Avançar"






2. Caso o erro ainda ocorra e se ocorrer somente para 1 usuário, efetue manutenção de profile desse usuário e verifique se o problema ainda ocorre:
MP - FRAME - Manutenção de Profile de Usuários

3. Se não for somente para 1 usuário, verifique direto no Dicionário SXB como estão suas informações, os dados devem estar exatamente igual ao print abaixo, caso não esteja efetue a manutenção:


Informações complementares
Pacote de Expedição Contínua do Gestão de Pessoal: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360057829854 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _