Ocorrência
Ao realizar atualização de release o processo fica parado sua porcentagem porém o tempo está contado, gerando dúvida se está ou não sendo realizado a atualização conforme evidência abaixo:
Imagem 1.
Imagem 2.
Ambiente
Retail Manager System, V12R27, V12R31, V12R32.
Causa
Conforme visto as imagens 1 e 2 em ocorrência, o tempo decorrido está sendo contado o que indica que a aplicação não está congelada, o que ocorre é que alguma job está sendo executada e bloqueando o 'Atualiza' de seguir com o seu processo, ou seja o Atualiza consegue parar todos os serviços quando se realiza a atualização, porém se tinha alguma job rodando antes de atualizar ao qual pode causar esse bloqueio.
Solução
Para solução é necessário realizar a consulta abaixo pelo banco de dados:
SELECT r.sid, r.job, r.this_date, r.this_sec, what
FROM dba_jobs_running r,dba_jobs j
WHERE r.job = j.job;
Está consulta vai retornar as informações da JOB que está sendo executada no momento e deve se anotar o SID da JOB.
Após isso realizar o select abaixo, ele trás as informações das seções que estão ativas junto com o seu SID, e o mesmo retorna ja com o comando para encerrar a seção o 'Alter System Kill Session', basta apenas copiar o comando do SID desejado e executar que a mesma vai ser encerrada e se retornar ao Atualiza o processo volta a fluir normalmente.
select 'alter system kill session '''||sid||','||serial#||','||'@'||inst_id||''' immediate;'
from gv$session
where username = 'RMS';
0 Comentários