Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Protheus - SIGAPCP - Mensagem FWFORMBEFORE ao excluir uma operação

time.png Tempo aproximado para leitura: 00:01:05 min

Ocorrência
Ao tentar excluir uma operação no MATA632 - Roteiro de Operações  ou no PCPA124 - Processo Produtivo o usuário recebe a mensagem FWFORMBEFORE - Violação de Integridade. Foi encontrada referência do produto (G2_PRODUTO) _ Código (G2_CODIGO) + Operação (G2_OPERAC) na tabela SGF - Amarr Operação x Componente. Formulário MATA632_SG2.

Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Protheus) - Planejamento e Controle da Produção (SIGAPCP) - Versão 12

Causa
Essa mensagem surge quando existe um relacionamento entre os componentes da estrutura e a operação que se deseja excluir.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse a rotina MATA637 - Operação x Componente;
2. Pesquise pelo produto do qual deseja remover a operação;
3. Clique em editar;
4. Veja quais são os componentes que estão vinculados com a operação em questão e exclua esse relacionamento;
5. Relacione os componentes com outra operação ou não faça o relacionamento, de modo que os componentes serão requisitados ao apontar a última operação.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _