Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS IND - PRO – Invalid field name.ORA-00904: CON_DECIMAL: invalid identifier

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
Após realizar a atualização no ambiente de testes do pimspi (pro.exe) para a versão 12.1.2506, o sistema apresenta uma falha crítica imediatamente ao ser aberto, impedindo o acesso do usuário. A mensagem exibida no pop-up Processo Industrial é: Invalid field name. ORA-00904: CON_DECIMAL: invalid identifier.

CONDE.png

Ambiente
TOTVS Agro - TOTVS Agro - Bioenergia - Controle Processo Industrial - PRO - Versão 12.1.2506

Causa 
Esse incidente ocorre devido à ausência de colunas necessárias na estrutura do banco de dados para a versão 12.1.2506, falta de execução dos scripts de dicionário/atualização nas tabelas PROCONFIGLOG e PROCONFIG. Como o Sistema tenta mapear os campos novos e eles não existem nas tabelas correspondentes, o Oracle retorna o erro de identificador inválido.

Solução
Para solucionar o problema, é necessário adicionar as colunas faltantes nas respectivas tabelas do banco de dados utilizando os comandos SQL abaixo.

-- Adiciona a coluna con_decimal na tabela de log de configuração
ALTER TABLE PROCONFIGLOG ADD con_decimal VARCHAR2(2);

-- Adiciona a coluna con_decimal na tabela de configuração ativa
ALTER TABLE PROCONFIG ADD con_decimal VARCHAR2(2);

-- Adiciona a coluna de início de safra de relatório na tabela de configuração ativa
ALTER TABLE PROCONFIG ADD con_inisafrelatorio VARCHAR2(1);
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _