O erro "array out of bounds (0 of 7) on RECALC(MATA190.PRX)" ocorre no recálculo do custo de entrada devido a inconsistências em TES ou cadastros no SIGAMAT, especialmente quando o campo F4_TRANFIL está incorretamente configurado como transferência entre filiais. A solução envolve verificar e corrigir o cadastro de TES e fornecedores para garantir correspondência correta de CNPJs, evitando falhas na rotina MATA190.
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Ocorrência
Ao processar a rotina de Recálculo do Custo de Entrada (MATA190), o sistema aborta apresentando o error log: "array out of bounds ( 0 of 7 ) on RECALC(MATA190.PRX)".
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque e Custos - Todas as versões
Causa
O incidente ocorre em virtude de uma inconsistência de dados referente à configuração de TES ou cadastros no SIGAMAT.
Porque o sistema encontrou movimentações de estoque/compras apontando para uma filial que não está configurada ou acessível no ambiente no momento do processamento.
Solução
Na maioria dos casos, o problema é devido a uma alteração de dados interna, o erro é acionado porque o campo F4_TRANFIL (Transferência entre Filiais) foi configurado com o conteúdo 1 (Sim) para uma operação que não representa uma transferência genuína entre filiais.
Com a opção de transferência habilitada, a rotina entende que a nota fiscal (SD1) provém de outra filial da empresa e tenta localizar a origem cruzando o CNPJ do Fornecedor da nota (SA2) com o CNPJ das filiais ativas no sistema (tabela SM0).
Como o CNPJ do fornecedor não corresponde ao CNPJ da matriz/filial, a rotina não encontra correspondência, atribuindo o valor 0 à variável de leitura do array e resultando na falha.
Verifique a natureza da nota fiscal bloqueada no erro.
Caso a operação seja referente a uma compra ou serviço padrão de um fornecedor externo, acesse o Cadastro de TES (MATA080), localize a TES utilizada e valide se teve de fato alteração no campo F4_TRANFIL, volte ao seu conteudo original.
Caso a operação seja, de fato, uma transferência entre filiais da mesma empresa, acesse o Cadastro de Fornecedores (MATA020) e certifique-se de que o fornecedor que representa a filial de origem possui a mesma raiz de CNPJ cadastrada para a filial de destino no SIGAMAT (SM0).
Após o ajuste do cadastro, execute o processamento da rotina MATA190 novamente.
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