Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - The required file is locked by another process ao criar instância PASOE

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao criar instância PASOE por linha de comando no Windows, o erro The required file is locked by another process é apresentado no Proenv.

Ambiente
Framework - Framework (Linha Datasul) - PASOE - A partir do OpenEdge 12

Causa 
Ao concluir a criação da instância do PASOE, o utilitário PASMAN atualiza o arquivo DLC\servers\pasoe\conf\instances.windows para registrar as informações do novo ambiente. 
O erro em questão ocorre porque o processo executado não possui privilégios de escrita para modificar esse arquivo.

Solução
Ainda que a sessão atual utilize um usuário com privilégios administrativos, esta atividade exige a elevação explícita de permissões. Para isso, execute o terminal PROENV utilizando a opção Executar como Administrador - Run as Administrator.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _