Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - FRW - Mensagem 57840 - DATASUL Interactive será encerrado! Não foi possível concluir a troca da empresa devido a um DIALOG que não pode ser encerrado.

time.png Tempo aproximado para leitura: 00:01:12 min

Ocorrência
Ao efetuar o Troca Empresa, é retornada a mensagem de advertência 57840 - DATASUL Interactive será encerrado! Não foi possível concluir a troca da empresa devido a um DIALOG que não pode ser encerrado.

Ambiente
Framework - Framework (Linha Datasul) - Básico (BTB) - Versão 12

Causa
Houve uma manutenção do Framework para corrigir um problema que encerrava o Datasul Interactive quando tentava trocar de empresa. Foi identificado que isto acontecia quando alguns programas já haviam sido abertos, mesmo já tendo a janela fechada, mas mantinham os handles presos na memória.
Um dos programas que causava esta situação era do Framework, mas isto pode ser causado também por outros programas de negócio e também específicos que vão apresentar o mesmo comportamento. O programa de Framework foi corrigido e junto com a correção, foi feita uma melhoria onde será apresentada uma mensagem de erro no log, informando qual programa está deixando handle preso na memória.

Solução
No caso de programas padrões, deverá ser aberto um ticket para a área de negócio responsável pelo programa corrigir o programa que está ocasionando o problema. Em caso de específico, o mesmo deverá ser revisado e ajustado pelo cliente.

Saiba mais
Segue documentação das implementação liberada: 20624075 DFWKDATASUL-6177 DT Datasul Interactive é encerrado na troca de empresa.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _