Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - Mensagem: ORA-04088 : erro durante a execução do gatilho 'U_CONY8J_WI.TRG_PCMOVENDPEND_NAODUPLIC'

time.pngTempo aproximado para leitura: 00:01:30 min

 

Ocorrência

No módulo Separação de Pedidos, rotina 1752 - Gerar mapa de separação/Abast. Corretivo - Pedido, ao processar a geração do mapa ocorre o erro: Erro: ORA-04091 : a tabela U_CONY8J_WI.PCMOVENDPEND é mutante; talvez o gatilho/função não possa localizá-la
ORA-06512 : em "U_CONY8J_WI.TRG_PCMOVENDPEND_NAODUPLIC", line 4
ORA-04088 : erro durante a execução do gatilho 'U_CONY8J_WI.TRG_PCMOVENDPEND_NAODUPLIC'

 

Ambiente

TOTVS Distribuição - WMS - Linha Winthor - 17 - WMS -  A partir da versão 30
 
 

Causa

Esse incidente ocorre devido à execução da trigger TRG_PCMOVENDPEND_NAODUPLIC na tabela PCMOVENDPEND durante operações DML (inserção ou atualização), gerando conflito por tratar-se de uma tabela mutante no contexto Oracle.
 
 

Solução

Para solucionar essa ocorrência, realize os seguintes passos:
 
1. Solicite autorização formal do responsável técnico/suporte DBA para alteração em objetos do banco;

2. Acesse o banco de dados Oracle com um usuário com permissões administrativas;

3. Execute o comando abaixo para desabilitar temporariamente a trigger:

  • ALTER TRIGGER U_CONY8J_WI.TRG_PCMOVENDPEND_NAODUPLIC DISABLE;

4. Retorne ao sistema Winthor e execute novamente a rotina 1752 - Gerar Mapa de Separação/Abast. Corretivo;

5. Valide se o processamento foi concluído sem apresentar novos erros.

 

Importante

Desabilitar triggers pode impactar regras críticas do negócio! Sempre valide impactos antes da ação definitiva.

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _