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Ocorrência
Ao tentar salvar ou processar um resgate na grid de lançamentos, o sistema bloqueia a ação, destaca a célula da coluna Valor Líquido em vermelho e exibe um ícone de "X" vermelho ao lado do valor, conforme demonstrado na imagem:
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Gesplan) - Operações Financeiras - Todas as versões
Causa
Este comportamento ocorre porque existe um Bloqueio Judicial cadastrado no contrato cobrindo 100% do saldo da aplicação. O sistema valida essa trava de segurança para impedir movimentações indevidas em saldos bloqueados por ordem jurídica.
Solução
Como o bloqueio judicial não pode ser removido ou editado com uma data final menor que o período já realizado/contabilizado, deve-se seguir o processo de contorno abaixo para permitir resgates parciais ou específicos autorizados:
1. Ajustar o bloqueio vigente: Acesse a tela de bloqueios do contrato e altere a Data Final do bloqueio judicial atual para 1 dia anterior à data em que deseja realizar o resgate;
2. Lançar o resgate: Cadastre o resgate desejado na grid, processe a movimentação e realize a sua devida contabilização/efetivação;
3. Reativar o saldo do bloqueio (se aplicável): Caso ainda reste saldo e seja necessário manter o controle do bloqueio judicial no sistema, cadastre um novo registro de bloqueio, definindo a Data de Início como sendo maior (posterior) à data de realização/contabilização do resgate feito no passo anterior.
Importante
Exclusão de resgates em aberto: Sempre que um bloqueio judicial é alterado, adicionado ou excluído, o sistema executa um processo interno para recalcular e gerar as datas do contrato. Se houver algum outro resgate em aberto no momento dessa alteração, ele será excluído automaticamente pelo processo.
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