Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAACD - Cannot find function :vtctrlperg on VTACHOICE(VT100.PRG) 08/05/2026 16:43:01 line : 1819

O erro no relatório de código de barras e etiquetas ocorre em várias rotinas no TOTVS Backoffice (Protheus) devido à ausência da função 'VtCtrlPerg'. A solução foi restaurar essa função, usada por um componente Frame via ACD. Recomenda-se atualizar o sistema para as versões 12.1.2310, 12.1.2410 ou 12.1.2510 e realizar backup antes da atualização, sempre testando em ambiente de teste.


time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Clica em relatórios - Código de barras - Etiqueta de produto apresenta o error.log , esse error.log apresenta também nessas outras rotinas (Etiqueta endereço) (Etiqueta de Transportadora) (Etiqueta sem titulo) ( Etiqueta usuários).


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Automação e Coleta de Dados - Todas as versões.

Causa 
Esse incidente ocorre, em outras rotinas (Etiqueta endereço) (Etiqueta de Transportadora) (Etiqueta sem titulo) (Etiqueta usuários).


Solução
Alterado rotina retornando a função 'VtCtrlPerg' pois é chamada por um componente do Frame no acesso via ACD.

 12.1.2310:https://r.totvs.io/p/1252750 ; 

12.1.2410:https://r.totvs.io/p/1252751 ; 

12.1.2510:https://r.totvs.io/p/1252749 ;

Issue TDN: DMANMAT01-48584
 
É importante atualizar seu produto constantemente, mantendo-o sempre na última versão disponível no Portal de Clientes (Central de Download), a fim de contemplar todas as melhorias e correções disponibilizadas.

Efetuar o Backup antes da atualização. Todos os procedimentos devem ser realizados primeiro em ambiente TESTE atualizado.

 

Saiba Mais:

Clique aqui e veja mais artigos sobre SIGAACD - Automação e Coleta de Dados

 DMANMAT01-48584: cannot find function :vtctrlperg on VTACHOICE(VT100.PRG) 08/05/2026 16:43:01 line : 1819
 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _