Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Erro de Constraint no SQL Server durante Atualização de Dicionário via Console Datasul

time.png Tempo aproximado para leitura: 00:01:20 min

Ocorrência
Na etapa de atualização de dicionário pelo Console de Atualização apresenta a mensagem, exemplo: 
The object 'DF__fda_lote___nr_tr__21BAC967' is dependent on column 'nr_trans'.
ALTER TABLE ALTER COLUMN nr_trans failed because one or more objects access this column.

Ambiente
Framework - Framework (Linha Datasul) - SQL Server - Versão 12

Causa 
Acontece porque está tentando alterar ou excluir a coluna, exemplo: nr_trans, mas existe uma Constraint, provavelmente um Default Value ou uma chave estrangeira vinculada a ela. O SQL Server protege a integridade dos dados impedindo alterações na coluna até que essa restrição seja removida.

Solução
O nome da restrição, exemplo: DF__fda_lote___nr_tr__21BAC967 é justamente o nome da restrição, para resolver isso, precisa seguir os passos a seguir.

Execute o comando para apagar a restrição que está bloqueando a alteração:

ALTER TABLE [dbo].[bem_pat_img] DROP CONSTRAINT [DF_bem_pat_icod_c_70D79AEA]

Procedimento para Correção na atualização via Console de Atualização do Datasul
1. Identifique qual banco de dados apresentou o erro e localize a pasta do pacote de scripts correspondente;
2. Verifique o nome da tabela e a constraint que está bloqueando a execução no log de erro;
3. Conecte-se ao SQL Server e execute uma query para eliminar a constraint identificada;
4. Execute diretamente no banco de dados o script do pacote que havia falhado;
5. Retorne ao Console de Atualização do Datasul e prossiga com as etapas restantes do processo.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _