Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - Erro ao executar fórmula: Já foi adicionado um item com a mesma chave


time.png Tempo aproximado para leitura: 00:03:55min

Ocorrência
Ocorreu o seguinte erro ao executar a formula "Código da Formula":
A fórmula "Código da Formula" não pode ser executada! Já foi adicionado um item com a mesma chave.

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Folha de Pagamento -Todas as versões

Causa
O erro ocorre devido a uma inconsistência ou quebra de integridade na base de dados do funcionário afetado. Quando o sistema realiza o processamento em lote (grandes grupos, filiais ou seções), ele tenta carregar e indexar as informações históricas e cadastrais na memória. Se houver registros com caracteres invisíveis (como um espaço em branco ao final do código) ou códigos que perderam a amarração com suas respectivas tabelas master, a aplicação gera a exceção de chave duplicada ao tentar adicionar o item no dicionário interno de cálculo.

Na maioria dos cenários mapeados, a causa está relacionada a:

  • Um caractere de espaço em branco inserido incorretamente ao final do campo CODHORARIO na tabela de Histórico de Horários (PFHSTHOR).

  • Um caractere de espaço em branco inserido incorretamente ao final do campo CODFUNCAO na tabela de Histórico de Funções (PFHSTFCO).

Solução

Como as validações de tela atuais do sistema impedem a gravação de códigos inexistentes ou com espaços, essas inconsistências são heranças de migrações antigas ou inserções diretas via banco de dados executadas no passado.

Realize os seguintes passos: 

  1. Identifique no log de execução do processo, qual é a chapa do funcionário em que o processamento é interrompido;
     

  2. Através de uma ferramenta de banco de dados (como SQL Server Management Studio), realize uma consulta nas tabelas de histórico do funcionário afetado para checar a existência de espaços em branco ao final dos códigos cadastrados. Utilize comandos que verifiquem o comprimento do caractere ou que evidenciem o espaço (exemplo: WHERE CODHORARIO LIKE '% ');
     

  3. Verifique especificamente o preenchimento dos campos nas seguintes tabelas:

  • Tabela PFHSTHOR, coluna CODHORARIO (Histórico de Horário).

  • Tabela PFHSTFCO, coluna CODFUNCAO (Histórico de Função).

  1. Realize o ajuste fino no banco de dados para remover o caractere de espaço em branco ao final do código (utilizando funções de tratamento de string como RTRIM), garantindo que o código fique idêntico à chave primária correspondente na tabela master (AHORARIO ou PFUNCAO);
     

  2. Após efetuar a correção na base de dados e retirar o espaço em branco das tabelas de histórico, acesse o sistema novamente e reexecute o processo de lançamento do grupo de eventos ou geração de encargos para o lote de funcionários.

Além das orientações apresentadas acima, recomendamos realizar a validação da base de dados conforme indicado no material abaixo. Como apoio à análise, também sugerimos utilizar ferramentas de banco de dados para monitorar e identificar possíveis ocorrências relacionadas ao erro.
 

Saiba Mais

RH - RM - FOP - Validação da Base de Dados

Framework - Framework RM - BD - Executando Profiler/Trace em uma Base de Dados Oracle

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _