Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAEST - Erro FWFormViewStruct SETPROPERTY Campo D2_(XPTO)não encontrado

Ao tentar incluir uma nota de débito (MATA600) no TOTVS Protheus, pode ocorrer erro relacionado a campos do dicionário de dados (ex.: D2_LOCALIZ) com restrição de uso em módulos incorretos. A solução é acessar o Configurador (SIGACFG), editar o campo no Dicionário de Dados, ajustar a restrição de módulos para o ambiente correto, salvar e atualizar o dicionário, permitindo o funcionamento da tela.

time.png Tempo aproximado para leitura: 00:01:00 min
 

Ocorrência
Ao tentar incluir uma nota de débito (MATA600), o sistema apresenta o seguinte erro: "erro no parâmetro FWFormViewStruct: O erro no método SETPROPERTY: Campo D2_LOCALIZ não encontrado. on FWFORMVIEWSTRUCT:SETPROPERTY". Este mesmo incidente pode ocorrer indicando outros campos do dicionário de dados pertinentes à tabela SD2, sendo os mais recorrentes os campos D2_LOCALIZ, D2_LOTECTL e D2_NUMSERI
 


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAEST - Todas as versões
 


Causa 
A ocorrência se deve ao fato de que o campo referenciado na mensagem de erro (como o D2_LOCALIZ) está com sua utilização restrita no Dicionário de Dados (SX3), associado especificamente a módulos que não correspondem ao uso do processo em questão (por exemplo, definido apenas para o SIGALOJA), ou não estar marcado como usado no configurador. Essa limitação de módulos afeta diretamente a composição de uso do campo na base (X3_USADO), fazendo com que a tela MVC não localize a propriedade durante a montagem da interface (FWFormViewStruct).
 


Solução

Para solucionar a ocorrência e permitir a abertura da tela, siga os passos abaixo:

  1. Acesse o módulo Configurador (SIGACFG).

  2. Siga pelo menu em Base de Dados > Dicionário > Bases de Dados.

  3. Posicione em "Dicionário de Dados" e clique na lupa para pesquisar o campo mencionado no erro (exemplo: D2_LOCALIZ, D2_LOTECTL ou D2_NUMSERI).

  4. Clique em Editar.

  5. Acesse a aba "Módulos".

  6. Remova a restrição, modificando o campo para todos os módulos ou marcando as caixas de seleção dos módulos específicos utilizados em seu ambiente.

  7. Confirme a alteração, salve e proceda com a Atualização do Dicionário de Dados.

  8. Acesse novamente a rotina afetada e confirme que a tela de entrada de dados voltará a funcionar normalmente.

 

Segue em anexo a SX3 da SD2 dos campos D2_LOTECTL, D2_LOCALIZ e D2_NUMSERI com a estrutura padrão para validação e comparação. 

OBS: Os dados são para auxílio e comparação em relação ao ambiente com o cenário. Caso queira utilizar o exemplo padrão, realizar um backup e avaliar se possui diferença nos tamanhos, formatos e pictures dos campos para não causar impactos no ambiente.

 

Saiba mais:

Como configurar a rotina MATA600 Notas de Débito?

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAEST - Nota de Débito do tipo 7 Perda em Estoque

Notas de Débito (MATA600) - ExecAuto

Clique aqui e veja mais artigos sobre Movimentações no Estoque

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _