Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - Doc. Eletrônicos - NFSE - invalid typecast in file E:\build-dir\TP11-OF2431X-W6\advpl\instrvar.inl at line 1068 on GETTPRETPCC(NFSEXMLENV.PRW) XX/XX/2026 11:02:31 line : XXXX

Ocorrência
Ao realizar a transmissão de uma nota, ocorre o error.log abaixo:

invalid typecast in file E:\build-dir\TP11-OF2431X-W6\advpl\instrvar.inl at line 1068
on GETTPRETPCC(NFSEXMLENV.PRW) 07/05/2026 11:02:31 line : 6045

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Todas as versões

Causa 
Esse error.log ocorre por conta do tipo do parâmetro MV_NT007 estar configurado incorretamente no ambiente, exemplo:



Solução
Para correção deverá ser ajustado o tipo do parâmetro para LÓGICO ao invés de CARACTERE e/ou outro:



Obs.: O parâmetro deverá ser configurado como True caso a prefeitura tenha aderido à NT 007, caso contrário, devera estar como False.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _