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Ocorrência
Ao ler o arquivo de retorno do banco Itaú no componente FCPFP070 - Retorno de Agendamento/Pagamento Eletrônico de Fornecedor, não carrega as duplicatas, as colunas referente a Emissão e Vencimento ficam zeradas e no frame Resposta, coluna Mensagem tem a seguinte informação:
999 - Duplicata não encontrada;
00 - Pagamento Efetuado.
Ambiente
TOTVS Varejo - Moda - Financeiro
Causa
Após o envio da remessa ao banco Itaú, o Totvs Moda aguarda o processamento do arquivo de retorno referente ao aceite dos títulos enviados. Quando esse arquivo é processado, é registrada na observação da duplicata a instrução BD - Pagamento agendado.
Esse processamento indica que o título está preparado para a próxima etapa, que é a baixa por meio do arquivo de retorno de pagamento, contendo a instrução 00 - Pagamento Efetuado.
Quando o arquivo de confirmação do agendamento BD - Pagamento agendado não é recebido ou processado, o fluxo é interrompido. Como consequência, os títulos não ficam aptos para carregamento no FCPFP070.
Solução
Para resolver esse cenário, é necessário verificar se o banco enviou o arquivo de retorno referente à confirmação do agendamento. Caso o arquivo não tenha sido enviado, será necessário solicitar o envio ao banco.
Também pode ocorrer do banco ter disponibilizado o arquivo, porém o usuário responsável pelo processo não ter identificado ou realizado sua leitura, seguindo diretamente para o processamento do arquivo de pagamento.
Em geral, após o envio da remessa, o banco costuma disponibilizar o arquivo de confirmação no mesmo dia. Já o arquivo referente à baixa/pagamento normalmente é disponibilizado no dia seguinte. Portanto, é importante garantir que a leitura ocorra na sequência correta para que o processo seja concluído sem inconsistências.
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