Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Logística - Linha Protheus - TMS - Campo [viagem.carga.natureza] inválido

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao integrar o TMS com a Pamcard, ocorre o erro Campo [viagem.carga.natureza] inválido.

Ambiente
TOTVS Logística - TOTVS TMS (Linha Protheus) - Gestão de Transportes (TMS) - Todas as versões

Causa 
A mensagem Campo [viagem.carga.natureza] inválido ao integrar com a Pamcard, ocorre se a tag viagem.carga.natureza não for enviada ou se o conteúdo da tag for inválido.

Solução
A tag viagem.carga.natureza deve ser preenchida com a seguinte regra:

  • Se  o Tipo de carga - DTR_TIPCRG = 2, considera a natureza do parâmetro MV_PAMNATC. O conteúdo deste parâmetro deve conter apenas o código da natureza, sem aspas;
  • Senão, busca o campo Tab. Nat. Receita - B1_TNATREC do produto do documento transportado - DTC_CODPRO.

Se estes cadastros estiverem conforme a regra citada e ainda assim ocorrer a falha, então, é necessário avaliar os logs da integração com a Pamcard. Para isso, basta habilitar o parâmetro MV_TMSXML para gerar os logs da integração na pasta /system/.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _