Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - Meu RH - Erro ao salvar anexo na rotina TCFA040 ao aprovar ou reprovar a requisição

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Quando a Equipe de RH vai aprovar uma requisição via rotina TCFA040, nos módulos SIGAGPE ou SIGAPON, o erro abaixo ocorre.


Ambiente
TOTVS RH (Linha Protheus) - Meu RH – todas as versões

Causa 
Este erro é proveniente de uma inconsistência na biblioteca webapp.dll que consta nas pastas do bin/appserver.

Solução
Disponibilizados nos links abaixo os arquivos atualizados do webapp.dll, já contendo a correção para a inconsistência reportada. O arquivo é o responsável direto pelo erro apresentado.

A equipe de Desenvolvimento do binário AppServer disponibilizou nova versão da DLL:

Windows:
https://build.tech.totvs.com.br/webapp/panthera_onca/builds/10.1.4-RC6/webapp-10.1.4-RC6-windows-x64-release.zip

Linux:
https://build.tech.totvs.com.br/webapp/panthera_onca/builds/10.1.4-RC6/webapp-10.1.4-RC6-linux-x64-release.tar.gz

Executar os procedimentos abaixo:

  • Paralisar os serviços de todos os AppServers (Master e Slaves);
  • Substituir o arquivo webapp.dll em todos os ambientes;
  • Reiniciar os serviços após a substituição.

Com a DLL atualizada, a inconsistência na gravação não deverá mais ocorrer.

Adicionalmente, recomenda-se, sempre que possível, a atualização do binário AppServer, LIB e DBAccess para versões atuais.

Ressalta-se que, conforme validado, a origem específica do erro está no arquivo webapp.dll.

Saiba Mais:
CLIQUE AQUI para acessar mais artigos e FAQs sobre o MEU RH
CLIQUE AQUI para acessar a documentação de referências sobre o MEU RH

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _