Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Erros 778 e 735

time.png Tempo aproximado para leitura: 00:01:20 min

Ocorrência
Na execução de alguma rotina do produto Datasul apresenta as mensagens:
Erro reading socket, ret=10053, erro=2. (778)
Gravação incompleta durante o processo de grava o no servidor. (735)

Ambiente
Framework - Framework (Linha Datasul) - Sessão Cliente - Versão 12

Causa 
Os erros 778 e 735 estão indicando que houve um problema de comunicação entre o Client e o Server do banco de dados em uma conexão que já estava estabelecida. A sessão Client tenta enviar uma mensagem ao Server, a comunicação falha e o erro é exibido em tela.

Solução
Desta forma, será necessário que você realize uma análise em sua rede local para verificar se algo pode estar derrubando a conexão entre o Client e o Server de banco de dados. Esta é uma tarefa complexa, pois a queda citada pode não afetar outras aplicações. O banco de dados é mais sensível a uma queda mínima de rede pois utiliza conexão socket. Qualquer queda, por mínima que seja, irá desconectar o usuário do banco de dados.

Realize testes de ping em seu ambiente, usando o exemplo abaixo entre os servidores de Aplicação, Banco de Dados e Programas para ver a conectividade. Valor ideal menor 1 milissegundos
 

ping -l 8192 -n 50 ip_banco
ping -l 8192 -n 50 ip_servidor_programas
ping -l 8192 -n 50 ip_servidor_pasoe


Especialmente da máquina que apresenta o erro para o Servidor de Programas e Banco de Dados afim de verificar se há alguma latência de rede.

Erro 10053: Geralmente está na estabilidade da conexão entre Client e o Server. Aguardou uma resposta, não recebeu, um Timeout e encerrou a conexão unilateralmente.
Erro 10054: Geralmente está no servidor ou no caminho da rede alguma aplicação no meio do caminho ou o próprio servidor encerrou a sessão.

Solicitar a análise da Infra para verificar as configurações de Firewall e TCP/IP no Server e Client,

Saiba mais
Alguns Kbases com mais informações acerca desta situação:
RANDOM ERRORS 778, READING RET=10054 ERRNO=2
WHAT IS REALLY BEHIND THE 778 ERROR AND IS IT CAUSED BY A PROGRESS TIMEOUT?
Error reading socket, ret=10054, errno=0. (778) running Client/Server with TCP/IP
 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _