Tempo aproximado para leitura: 00:01:50 min
Ocorrência
Após atualizar para versão 12.1.2603.2 - 12.1.2511.8 - 12.1.2507.14 ou acima, a tela html.cc0509 - Consulta de Pedido de Compra não esta abrindo ao acessar pelo menu.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Compas (MCC) - Versão 12
Causa
Essa situação ocorre, pois houve uma alteração no nome externo do programa html.cc0509 - Consulta de Pedido de Compra e por tanto precisaria ajustar manualmente ou realizar atualização de menu.
Solução
Há duas possibilidades de solucionar o erro:
A primeira seria atualizando o menu:
Para atualizar o menu de um módulo do Datasul 12, acesse o programa Importação Menu Datasul - men706aa e selecione a opção Por Arquivo. No campo Arquivo, busque o arquivo de menu do módulo à ser importado, nesse caso deve ser o arquivo men_mcc.d
Os arquivos de menu do Datasul 12 são expedidos e encontrados na pasta ...\ERP\fnd\univdata
A segunda possibilidade de solução, seria alterar o nome externo do programa html.cc0509 - Consulta de Pedido de Compra manualmente:
Para realizar essa ação, deve acessar o programa bas_prog_dtsul - Manutenção de Programas e localizar o registro html.cc0509
Ao encontrar o registro deve clicar em opção alterar, vá no campo "Nome Externo" e remova a barra final do endereço.
Antes estaria assim: dts/mcc/purchaseorder/detail/
Então deve ficar assim: dts/mcc/purchaseorder/detail
Importante: Como boa pratica, sugerimos que ao atualizar versão do produto também atualize os arquivos de menu.
Saiba mais: Para saber como atualizar um ou vários arquivos de menu consulte o artigo:
Framework - Linha Datasul - FRW - Atualização de menu no produto Datasul 12
0 Comentários