Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - Aviso de violação de chave estrangeira na tabela PFPERFF ao liberar competência


time.png Tempo aproximado para leitura: 00:02:33 min

Ocorrência
Ao realizar o processo de liberação de competência no módulo Folha de Pagamento, o sistema apresenta o seguinte aviso: "Não foi possível transferir os dados da tabela PFPERFF. Existe algum campo nesta tabela cujo valor está violando a chave estrangeira. Verifique qual valor é este e cadastre o registro na tabela correspondente.

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões

Causa 
O aviso ocorre porque, durante o processo de liberação de competência, o sistema realiza a transferência/cópia da movimentação e do período da ficha financeira normal (tabelas PFFINANC e PFPERFF) para a ficha financeira complementar (tabelas PFFINANCOMPL e PFPERFFCOMPL).

Este alerta de violação de dados indica que os registros que o sistema tenta copiar já existem nas tabelas complementares. Isso pode acontecer devido a importações prévias de fichas financeiras ou restaurações de dados.

Embora a mensagem seja apresentada, o processo de liberação de competência é concluído. O aviso serve para que o usuário valide se os dados nas tabelas complementares estão fidedignos. Caso os dados já estejam corretos na ficha complementar, a mensagem pode ser ignorada.


Solução
Para que o sistema não emita mais o aviso, é necessário identificar e remover os registros duplicados:

  1. Identifique quais registros já constam nas tabelas de ficha financeira complementar (PFFINANCOMPL/PFPERFFCOMPL) que são idênticos aos da ficha normal que está sendo liberada;
     

  2. Solicite ao setor de T.I. ou ao DBA da empresa que realize uma consulta via banco de dados para localizar esses valores duplicados;
     

  3. Após a conferência da integridade dos dados, realize a exclusão dos registros duplicados em uma das tabelas para que a transferência ocorra sem alertas em futuras liberações.

 

Importante

Uma vez que o processo de liberação de competência foi concluído, não será possível desfazê-lo ou posteriormente retornar para a competência anterior.

 

Saiba mais

RH - RM - FOP - Liberação de competência

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _