Tempo aproximado para leitura: 00:01:45 min
Ocorrência
Ao tentar realizar o processo de Cancelar/Desautorizar Extra Autorizada, o sistema finaliza com ressalvas informando que não foram encontradas extras autorizadas conforme a seleção de funcionários, ou o processo não surte efeito mesmo com extras visíveis no espelho.
Ambiente
RH - RH (Linha RM) - TOTVS Automação de Ponto - Todas as versões
Causa
A mensagem de que não foram encontradas extras para cancelamento ocorre quando não existe o registro correspondente na tabela de extras autorizadas (AEAUTFUN). O processo de Cancelar Extra Autorizada aplica-se exclusivamente para funcionários que tiveram a autorização de extras executada por rotinas globais de autorização ou configuradas manualmente de forma individual diretamente no espelho.
Caso o funcionário possua a autorização configurada de forma nativa (ex: 24:00 horas diariamente definido no Parametrizador do Funcionário etapa Extra), não há um registro de autorização para ser cancelado pela rotina de cancelamento.
Solução
Para desautorizar horas extras em cenários onde a autorização é nativa ou quando o processo de cancelamento padrão não encontrar registros, siga as orientações abaixo:
-
Acesse em Configurações | Parametrizador | Iniciais | Cálculo e marque o parâmetro Extra aprovada sobrepõe as extras parametrizadas para o funcionário:
Após, acesse o menu Processos | Autorização | verifique as datas e a seleção de funcionários a serem considerados, marque o parâmetro Extra Autorizada | Autorizar Extra e no campo referente ao número de horas, informe o valor 00:00, execute o processo:
Dessa forma, o sistema gravará uma autorização de 00:00 (zero horas), fazendo com que todas as extras calculadas para a data se tornem não autorizadas, após recalcular o espelho de ponto, será possível verificar no Resumo e também em Anexos | Extra Autorizada que o valor mostrará 00:00:
Saiba mais
0 Comentários