Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RM - Customização - BSO Gestor XML - Erro invalid child element

Ocorrência

Ao realizar a integração ou importação de XMLs com as novas tags, o Gestor XML não aceita o arquivo. O sistema apresenta a seguinte mensagem de erro no log: "The element 'total' in namespace 'http://www.portalfiscal.inf.br/nfe' has invalid child element"

Ambiente

Cross Segmento - TOTVS Backoffice (Linha RM) - Gestão de Estoque, Compras e Faturamento / Gestor XML - 12.1.2506

Causa

Esse erro ocorre porque os Schemas do Gestor XML estão desatualizados em relação aos novos leiautes da NF-e.

Solução

Para corrigir a rejeição e atualizar os arquivos de validação, siga os passos abaixo:

  1. Acesse o portal da NF-e através do link disponibilizado pela Sefaz: Portal da NF-e.

  2. Baixe o pacote do Esquema XML atualizado (exemplo: Esquema XML NF-e/NFC-e - Pacote de Liberação nº 010b v. 1.30) no formato ZIP.

  3. No servidor ou máquina onde o serviço está configurado, acesse o diretório correspondente aos schemas: C:\totvs\GestorXML\Schemas\NFe\v400.

  4. Faça um backup prévio desta pasta v400 por segurança.

  5. Extraia os arquivos baixados do portal da NF-e e cole os novos schemas dentro da pasta C:\totvs\GestorXML\Schemas\NFe\v400.

  6. Após substituir os schemas, processe a importação do XML novamente.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _