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Ocorrência
Durante a geração da cotação no Novo Fluxo de Compras, ao tentar adicionar ou editar um contato de um fornecedor, o sistema exibe um alerta indicando a falta de preenchimento de campos obrigatórios.
"Não é possível completar a ação. Existem campos obrigatórios não preenchidos"
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Protheus) - Compras/GCT - A partir da Release 12.1.2310
Causa
A validação que impede a conclusão do processo não é originada do formulário de contatos de fornecedor DKI (Contatos x Fornecedores), mas sim do cadastro principal do fornecedor SA2.
Portanto, existem campos obrigatórios não preenchidos na tabela SA2 (tabela referente ao Cadastro de Fornecedor). Ao processar a adição ou edição do contato na cotação, o sistema realiza uma checagem de integridade do fornecedor e dispara o help devido à ausência desses dados obrigatórios na SA2.
Solução
Para solucionar o problema reportado, basta efetuar o procedimento abaixo.
Acesse a rotina padrão de Cadastro de Fornecedores no sistema.
Localize o cadastro do fornecedor exato em que a tentativa de edição/inclusão de contato apresentou o erro.
Clique na opção Alterar (ou Editar) para abrir o formulário principal do fornecedor e clique em Salvar
O sistema irá acusar qual ou quais campos obrigatórios estão em branco (geralmente destacados ou sinalizados ao tentar confirmar a tela).
Preencha as informações faltantes e confirme a gravação (salve) do cadastro do fornecedor.
Após a validação e correção do fornecedor, retorne à rotina de Cotação no Novo Fluxo de Compras e refaça a operação de incluir/editar o contato.
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