Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - PTO - "Erro ao inserir abono"

time.png Tempo aproximado para leitura: 00:01:20 min

Ocorrência
Ao incluir um abono para o funcionário, o sistema emite uma mensagem de erro: "Erro ao tentar inserir abono com coligada 1, chapa 12345, data de referência 01/01/2026 e número de horas 01:00:00. Erro ao inserir abono". Ou "Erro ao tentar inserir abono com coligada 1, chapa 12345, data de referência 01/01/2026 início 07:00 e fim 08:00. Problema: Chave duplicada"

Ambiente
RH - RH (Linha RM) - TOTVS Automação de Ponto - Todas as versões

Causa 
Este erro ocorre normalmente quando o ID da tabela GAUTOINC está dessincronizado com o ID da tabela AABONOFUNCIONARIO.

Solução
Para verificar se há esta dessincronização, com o apoio de um DBA, deverá executar a query abaixo para conferência:
Consulta 1:

SELECT * FROM GAUTOINC WHERE CODAUTOINC = 'IDABONOFUNCIONARIO'
 

Consulta 2:

SELECT CODCOLIGADA, MAX(ID) AS ID FROM AABONOFUNCIONARIO GROUP BY CODCOLIGADA
 

  • Se houver divergência entre os ID's retornados na consulta, no caso quando o ID da AABONOFUNCIONARIO está maior que o ID da GAUTOINC irá ocorrer o erro. 
  • Quando o ID da GAUTOINC estiver maior ou igual ao ID da AABONOFUNCIONARIO não há problema.

Imagem com os ID's dessincronizados, onde o ID da AABONOFUNCIONARIO é maior que o ID da GAUTOINC, que resulta no erro:


 

Com o apoio de um DBA, deverá executar o script abaixo para igualar os ID's (efetuar um backup da base de dados antes da execução):
 

UPDATE GAUTOINC SET VALAUTOINC = (SELECT MAX(ID) FROM AABONOFUNCIONARIO WHERE CODCOLIGADA = 1) WHERE CODAUTOINC = 'IDABONOFUNCIONARIO' AND CODCOLIGADA = 1

No exemplo acima, o problema foi identificado na coligada 1. Portanto, a query de UPDATE foi executada considerando essa coligada. Após a execução, e realizando novamente as consultas 1 e 2, mostrará sincronização:


Após o ajuste poderá incluir o abono normalmente.

Saiba mais
RH - RM - PTO - Como Inserir abono no espelho do funcionário

Importante
Caso você seja cliente Cloud Totvs, deverá abrir um ticket com o time de Cloud para solicitar a execução do UPDATE.

Se ao executar a consulta para avaliar se há a dessincronização dos ID's, os mesmos estiverem sincronizados, a causa raiz poderá ser outra. Nesta situação deverá acionar o time de suporte para análise.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _