Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - PTO - TOTVS RH (Linha RM) - Automação de Ponto - Erro ao executar o recálculo do ponto individual ou global

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao tentar realizar o recálculo do ponto (individual ou global), ocorre o erro  'The process cannot access the file 'C:\CorporeRM\RM.Net\ RMCHRONUS_CALCULO_LOG.txt' because it is being used by another process', impedindo o recalculo dos funcionários.

Ambiente
RH - RM - PTO - TOTVS RH (Linha RM) - Automação de Ponto - todas as versões

Causa 

O incidente geralmente é causado quando outro job ou processo esteja acessando o arquivo de log RMCHRONUS_CALCULO_LOG.txt simultaneamente ao recálculo do ponto. Esse arquivo de log é bloqueado enquanto está sendo escrito, e se outro processo tentar acessá-lo, o erro é disparado.


Solução
 

  1. Verifique na guia Ambiente | Gerenciamento de Jobs se existe Jobs concorrente;

  2. No módulo Automação de Ponto, acesse Movimento | Calcular | edite o perfil salvo e desmarque o parâmetro 'Gera arquivo de LOG técnico':

     
  3. Execute o recálculo novamente e valide se o recálculo será concluído com sucesso.

    Saiba mais
    Framework - Linha RM - Frame - Identificar job agendado
    Calcular Movimentação

     

     

     

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _