Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Varejo Supermercados - Operação Servidor - Gestor de PDVs - Reinicialização de subprocessos do monitor de PDVs Linux

time.png Tempo aproximado para leitura: 00:04:00 min

Ocorrência
Reinicialização de subprocessos do serviço de monitor de PDV no servidor, geralmente o aviso ocorre no terminal do servidor Linux com uma mensagem destacada em vermelho:



Ambiente
Monitor de PDVs - Aplicável para todas as versões.

Causa 
O serviço é composto por subprocessos responsáveis por diferentes etapas da operação do PDV.

Em caso de falha, o sistema realiza a reinicialização automática do subprocesso afetado.


O que cada subprocesso faz

  • Subprocesso 1 - Processo principal responsável por abrir os demais e monitorar
    Responsável por manter o serviço em execução e supervisionar os demais processos.
  • Subprocesso 2 - Comunicação TCP/IP
    Controla a conexão entre os caixas e o servidor.
  • Subprocesso 3 - Processos automáticos
    Executa rotinas automáticas, como geração de cargas e atualizações.
  • Subprocesso 4 - Processamentos de dados 
    Trata as informações recebidas antes de serem registradas.
  • Subprocesso 5 - Receber movimentos dos PDVs
    Recebe as vendas realizadas nos PDVs.
  • Subprocesso 6 - Gravar os movimentos dos PDVs no banco
    Registra as vendas no banco de dados.
  • Subprocesso 7 - Enviar carga para os PDVs
    Envio de cargas, do Monitor para o os PDVs e assim atualizando os dados no PDV.
  • Subprocesso 8 - DFe
     Responsável por integrações fiscais, como NFC-e.
  • Subprocesso 9 - Exportar movimento externo
    Envia informações para sistemas externos/terceiros.
  • Subprocesso 10 - Status de conexão serviço
    Monitora a saúde da comunicação do serviço.
     

Quando é normal o subprocesso reiniciar?

  • Reinício pontual sem impacto
  • Sistema segue operando normalmente


Quando acionar o suporte?

  • Falha na comunicação com PDVs
  • Vendas não processadas/integradas
  • Lentidão de cargas ou travamentos
  • Reinicializações constantes


Importante
Nem toda reinicialização indica falha. O sistema possui mecanismos automáticos de recuperação.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _