Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Varejo - Moda - PRD - Ao tentar excluir o grupo através do PRDFP035 é apresentado a validação ''Restrição de integridade (PRD_GRUPO_CDF_PRPOPC) registro filho localizado''

time.pngTempo aproximado para leitura: 05:00 min

Ocorrência
Após excluir os produtos por meio da rotina PRDFP035, ao tentar excluir o grupo, é apresentada a seguinte validação:
 

erro1.png

Ambiente
TOTVS Varejo - TOTVS Moda - Produto - Todas as versões

Causa 
Para que seja possível excluir um grupo de produto, ele não pode estar vinculado a nenhum outro processo. Nesse caso, a validação ocorre porque existe uma programação cadastrada para o grupo (CDFFM010).

Solução
Para solucionar essa ocorrência, realize os seguintes passos:,

  1. Acesse o CDFFM010
  2. Dê um duplo clique no campo Programação; será acionado o componente CDFFL003.
  3. Nele, pressione F4 para listar todas as programações cadastradas. No frame Programação padrão, serão exibidas as programações cadastradas no ambiente. Ao clicar sobre as colunas, é possível ordená-las para facilitar a consulta. 
  4. Ao encontrar a programação cadastrada para o grupo, dê um duplo clique sobre ela para que o sistema retorne ao CDFFM010 com a programação carregada na tela.
  5.  Em seguida, com o foco no campo Programação, pressione F8 para remover e, depois, F3 para salvar.
  6. Após excluir a programação retorne ao cadastro do produto para concluir a exclusão do grupo.

Exemplo:
 

PRDFP035.gif
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _