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Cross Segmentos - TOTVS Backoffice (Linha RM) - Doc. Eletrônicos - Enviar Evento: Não foi possível enviar o(s) evento(s): Chave duplicada

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Ocorrência
Ao tentar transmitir um evento de NF-e (como Carta de Correção), o sistema interrompe o processo apresentando a mensagem: 

"Enviar Evento: Não foi possível enviar o(s) evento(s): Chave duplicada. Possíveis causas: inclusão de registro cujo valor da chave primária já existe ou inclusão de registro cujo valor do índice único já existe".

Dúvida 
Como resolver a mensagem de erro "Chave duplicada" ao enviar eventos de NF-e no RM, e quais as possíveis validações para identificar a origem do problema?

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) - Documentos Eletrônicos - NFE - Todas as Versões

Causa
Ao tentar transmitir um evento de NFE, a mensagem de erro "Chave duplicada" ocorre, devido a uma inconsistência na tabela TNFEESTADUAL, onde os campos IDTSS e XMLNFE (essenciais para a correta transmissão de eventos) encontram-se em branco para o registro solicitado.

Este cenário geralmente ocorre, quando as notas fiscais são incluídas no sistema por um fluxo diferente do padrão esperado (RM → TSS → Órgão Autorizador). Sem o identificador do TSS e o conteúdo do XML autorizado gravados, o sistema não consegue processar o evento corretamente, ocasionando a violação de chave por falta de dados referenciais necessários para a integração.

Solução
Para resolução, deve-se validar se a nota fiscal foi emitida originalmente pelo RM ou por um sistema externo.
Conforme identificado, o envio de eventos somente funcionará corretamente quando o fluxo padrão de integração for seguido, onde os registros são devidamente gravados nas tabelas com todas as informações necessárias.

Caso a nota tenha sido emitida por outro software, as informações de IDTSS e XML não estarão presentes na base de dados do RM, impossibilitando a geração do evento pelo ERP.
 

Passos necessários para validação:

  1. Realize a seguinte consulta na base de dados do RM para identificar se os campos IDTSS e XMLNFE da nota em questão estão nulos: SELECT XMLNFE, IDTSS, * FROM TNFEESTADUAL WHERE IDMOV = 'Identificador Do Movimento'
     

  2. Execute a consulta abaixo para listar todos os registros que possam estar na mesma condição de inconsistência: SELECT XMLNFE, IDTSS, * FROM TNFEESTADUAL WHERE IDTSS IS NULL AND CODCOLIGADA = 'Número da Coligada'
     

  3. Verifique na base de dados do TSS se o documento consta como autorizado através do comando:. SELECT STATUS, STATUSCANC, * FROM SPED050 WHERE DOC_ID = 'Número do Movimento Sem Zeros À Esquerda'
     

  4. Valide junto ao setor de faturamento se a nota fiscal foi autorizada por um sistema terceiro ou processo de importação.
     

  5. Caso a nota seja de origem externa, o envio de eventos (como Carta de Correção) deve ser realizado obrigatoriamente através do software que autorizou a nota original, pois o RM não possui o histórico de transmissão necessário.
     

  6. Para regularizar processos futuros e evitar novas ocorrências, garanta que todas as notas fiscais sejam geradas e transmitidas integralmente através do RM.

 

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