Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework – Protheus – Problema nas fórmulas ao integrar com Excel (Apexcel)

⏱ Tempo aproximado para leitura: 00:00:46 min

Ocorrência
Na rotina Miscelânea > Integrações, ao gerar uma planilha Excel, as fórmulas ficam desconfiguradas

Ambiente
Integrações - Planilha Excel (Apexcel)

Causa
Este cenário ocorre devido a uma mudança na LIB de março/2026 (20260302), onde a busca do arquivo apexcel80.xla foi alterada de "C:\apexcel" para a pasta web-agent, que fica no perfil do usuário

Solução
Para solucionar este cenário, é necessário realizar os seguintes passos:

  1. Certificar de que o Web-Agent está em execução no computador do usuário

     

  2. Na fórmula, retire a informação 'C:\ApExcel\apexcel80.xla'!, que está apontando para o antigo caminho do arquivo apexcel80.xla. Com o Web Agent em execução, o arquivo será localizado automaticamente no perfil do usário, dentro da pasta web-agent (C:\"Usuário"\AppData\Local\Programs\web-agent)

 

Obs.: Com a ferramenta localizar do Excel, pode ser utilizada a opção "Substituir tudo" para limpar o caminho 'C:\ApExcel\apexcel80.xla'! de todas as fórmulas da planilha


 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _