Tempo aproximado para leitura: 00:02:15 min
Ocorrência
Ao realizar o download do relatório espelho de ponto no Meu RH, é apresentado a mensagem de erro: "There is no row at position 0".
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Meu RH - Todas Versões
Causa
Esse erro ocorre, quando a parametrização do download do espelho de ponto para o Meu RH está incompleta ou incorreta.
Solução
Para que o download do espelho de ponto funcione corretamente, é necessário realizar as seguintes validações:
-
Parametrização do relatório no grupo de quiosque
O relatório deve estar vinculado ao grupo de quiosque associado aos funcionários, no seguinte caminho:
Automação de Ponto | Configurações | Parametrizador | RM Portal | Espelho Funcionário | Código do Relatório
-
Configuração do tipo do relatório
Para que o relatório seja listado no campo "Código do Relatório", é necessário que, em sua estrutura acessada através do caminho Gestão | RM Reports, o campo Tipo esteja configurado como 181 - Espelho do Cartão de Ponto.
-
Criação do perfil de parâmetros
Após vincular o relatório, é necessário criar um perfil de parâmetros com o nome "MeuRH", contendo os parâmetros desejados. Esse perfil será utilizado na geração do relatório pelo app Meu RH, no caminho: Automação de Ponto | Relatórios | Espelho do Cartão
Após realizar essas configurações, o relatório deverá ser gerado corretamente no Meu RH, sem a ocorrência do erro informado.
Importante: Caso o erro persista, o problema pode estar relacionado ao relatório utilizado. Neste cenário, recomendamos que acesse o TOTVS Compartilhamento e faça o download novamente do relatório padrão código "PTOREL 01.0001" e durante a importação, marque a opção "Sobrescrever Existente". Após reimportar, é necessário atualizar o Grupo de Quiosque novamente, vinculando o novo relatório em "Código do Relatório".
Saiba Mais:
RH - RM - Meu RH - Como habilitar o download do espelho de ponto no Meu RH
0 Comentários